<!DOCTYPE html>
<html>
<head>
  <!--[if IE]><![endif]-->
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<link rel="shortcut icon" href="http://www.csnphilly.com/sites/all/themes/custom/nbcsports/favicon.ico" type="image/vnd.microsoft.icon" />
<meta name="tp:EnableExternalController" content="true" />
<link rel="amphtml" href="http://www.csnphilly.com/philadelphia-flyers/flyers-likely-end-one-two-top-centermen-draft?amp" />
<link href="/sites/all/themes/custom/nbcsports/img/apple-touch-icons/rsn/ios/apple-touch-icon-57x57.png" rel="apple-touch-icon" sizes="57x57" />
<link href="/sites/all/themes/custom/nbcsports/img/apple-touch-icons/rsn/ios/apple-touch-icon-57x57-precomposed.png" rel="apple-touch-icon-precomposed" sizes="57x57" />
<link href="/sites/all/themes/custom/nbcsports/img/apple-touch-icons/rsn/ios/apple-touch-icon-72x72-precomposed.png" rel="apple-touch-icon-precomposed" sizes="72x72" />
<link href="/sites/all/themes/custom/nbcsports/img/apple-touch-icons/rsn/ios/apple-touch-icon-72x72.png" rel="apple-touch-icon" sizes="72x72" />
<meta name="description" content="The Flyers somehow ended up with the second pick in this year&#039;s draft, which means they&#039;re guaranteed to land a top centerman. By Tim Panaccio" />
<link href="/sites/all/themes/custom/nbcsports/img/apple-touch-icons/rsn/ios/apple-touch-icon-114x114.png" rel="apple-touch-icon" sizes="114x114" />
<link href="/sites/all/themes/custom/nbcsports/img/apple-touch-icons/rsn/ios/apple-touch-icon-114x114-precomposed.png" rel="apple-touch-icon-precomposed" sizes="114x114" />
<link href="/sites/all/themes/custom/nbcsports/img/apple-touch-icons/rsn/ios/apple-touch-icon-120x120-precomposed.png" rel="apple-touch-icon-precomposed" sizes="120x120" />
<link href="/sites/all/themes/custom/nbcsports/img/apple-touch-icons/rsn/ios/apple-touch-icon-120x120.png" rel="apple-touch-icon" sizes="120x120" />
<meta name="robots" content="follow, index" />
<link href="/sites/all/themes/custom/nbcsports/img/apple-touch-icons/rsn/ios/apple-touch-icon-144x144-precomposed.png" rel="apple-touch-icon-precomposed" sizes="144x144" />
<link href="/sites/all/themes/custom/nbcsports/img/apple-touch-icons/rsn/ios/apple-touch-icon-144x144.png" rel="apple-touch-icon" sizes="144x144" />
<link href="/sites/all/themes/custom/nbcsports/img/apple-touch-icons/rsn/ios/apple-touch-icon-152x152-precomposed.png" rel="apple-touch-icon-precomposed" sizes="152x152" />
<meta name="news_keywords" content="Flyers, NHL draft, Tim Panaccio. Nolan Patrick, Nico Hischier, Nolan Patrick Flyers, Nico Hischier Flyers" />
<link href="/sites/all/themes/custom/nbcsports/img/apple-touch-icons/rsn/ios/apple-touch-icon-152x152.png" rel="apple-touch-icon" sizes="152x152" />
<link href="/sites/all/themes/custom/nbcsports/img/apple-touch-icons/rsn/ios/apple-touch-icon-180x180.png" rel="apple-touch-icon" sizes="180x180" />
<link href="/sites/all/themes/custom/nbcsports/img/apple-touch-icons/rsn/ios/apple-touch-icon-180x180-precomposed.png" rel="apple-touch-icon-precomposed" sizes="180x180" />
<meta name="rating" content="general" />
<meta name="generator" content="Drupal 7 (http://drupal.org)" />
<link rel="image_src" href="http://www.csnphilly.com/sites/csnphilly/files/2017/05/01/ap-ron-hextall.jpg" />
<link rel="canonical" href="http://www.csnphilly.com/philadelphia-flyers/flyers-likely-end-one-two-top-centermen-draft" />
<link rel="shortlink" href="http://www.csnphilly.com/node/516466" />
<meta property="og:site_name" content="CSN Philly" />
<meta property="og:type" content="article" />
<meta property="og:url" content="http://www.csnphilly.com/philadelphia-flyers/flyers-likely-end-one-two-top-centermen-draft" />
<meta property="og:title" content="Flyers likely to end up with one of two top centermen in draft" />
<meta property="og:description" content="The Flyers somehow ended up with the second pick in this year&#039;s draft, which means they&#039;re guaranteed to land a top centerman. By Tim Panaccio" />
<meta property="og:updated_time" content="2017-05-01T15:51:10-04:00" />
<meta property="og:image" content="http://www.csnphilly.com/sites/csnphilly/files/2017/05/01/ap-ron-hextall.jpg" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:url" content="http://www.csnphilly.com/philadelphia-flyers/flyers-likely-end-one-two-top-centermen-draft" />
<meta name="twitter:title" content="Flyers likely to end up with one of two top centermen in draft" />
<meta name="twitter:description" content="The Flyers somehow ended up with the second pick in this year&#039;s draft, which means they&#039;re guaranteed to land a top centerman. By Tim Panaccio" />
<meta name="twitter:image" content="http://www.csnphilly.com/sites/csnphilly/files/2017/05/01/ap-ron-hextall.jpg" />
<meta property="article:author" content="https://www.facebook.com/tpanotchCSN/" />
<meta property="article:published_time" content="2017-05-01T11:15:35-04:00" />
<meta property="article:modified_time" content="2017-05-01T15:51:10-04:00" />
  <meta http-equiv="X-UA-Compatible" content="IE=edge"><script type="text/javascript">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</script>
  <meta name=viewport content="width=device-width, initial-scale=1, maximum-scale=1.0, user-scalable=no">
  <title>Flyers likely to end up with one of two top centermen in draft | CSN Philly</title>
  <!-- Don't remove this. We are loading base file at first -->
  <style id="base-css">html{font-family:sans-serif;-ms-text-size-adjust:100%;-webkit-text-size-adjust:100%}body{margin:0}article,aside,details,figcaption,figure,footer,header,main,nav,section,summary{display:block}audio,canvas,progress,video{display:inline-block;vertical-align:baseline}audio:not([controls]){display:none;height:0}[hidden],template{display:none}a{background:transparent}a:active,a:hover{outline:0}abbr[title]{border-bottom:1px dotted}b,strong{font-weight:bold}dfn{font-style:italic}h1{font-size:2em;margin:0.67em 0}mark{background:#ff0;color:#000}small{font-size:80%}sub,sup{font-size:75%;line-height:0;position:relative;vertical-align:baseline}sup{top:-0.5em}sub{bottom:-0.25em}img{border:0}svg:not(:root){overflow:hidden}figure{margin:1em 40px}hr{box-sizing:content-box;height:0}pre{overflow:auto}code,kbd,pre,samp{font-family:monospace, monospace;font-size:1em}button,input,optgroup,select,textarea{color:inherit;font:inherit;margin:0}button{overflow:visible}button,select{text-transform:none}button,html input[type="button"],input[type="reset"],input[type="submit"]{-webkit-appearance:button;cursor:pointer}button[disabled],html input[disabled]{cursor:default}button::-moz-focus-inner,input::-moz-focus-inner{border:0;padding:0}input{line-height:normal}input[type="checkbox"],input[type="radio"]{box-sizing:border-box;padding:0}input[type="number"]::-webkit-inner-spin-button,input[type="number"]::-webkit-outer-spin-button{height:auto}input[type="search"]{-webkit-appearance:textfield;box-sizing:content-box}input[type="search"]::-webkit-search-cancel-button,input[type="search"]::-webkit-search-decoration{-webkit-appearance:none}fieldset{border:1px solid #c0c0c0;margin:0 2px;padding:0.35em 0.625em 0.75em}legend{border:0;padding:0}textarea{overflow:auto}optgroup{font-weight:bold}table{border-collapse:collapse;border-spacing:0}td,th{padding:0}html{font-family:Arial, Helvetica, sans-serif}a{text-decoration:none}h1,.alpha,h2,.beta,h3,.gamma,h4,.delta,h5,.epsilon,h6,.zeta{font-family:Arial, Helvetica, sans-serif;text-transform:uppercase}h1 a,h1 a:visited,.alpha a,.alpha a:visited,h2 a,h2 a:visited,.beta a,.beta a:visited,h3 a,h3 a:visited,.gamma a,.gamma a:visited,h4 a,h4 a:visited,.delta a,.delta a:visited,h5 a,h5 a:visited,.epsilon a,.epsilon a:visited,h6 a,h6 a:visited,.zeta a,.zeta a:visited{text-decoration:none}h1,.alpha{font-family:"BebasNeue", Arial, Helvetica, sans-serif;font-size:40px;font-size:2.5rem;font-weight:400}h2,.beta{font-size:34px;font-size:2.125rem}h3,.gamma{font-size:21px;font-size:1.312rem}h4,.delta{font-size:18px;font-size:1.125rem}h5,.epsilon{font-size:16px;font-size:1rem}h6,.zeta{font-size:16px;font-size:1rem}p{margin:0 0 1em}blockquote{padding:0 1.5em;font-style:italic}blockquote p{margin:0}q{font-style:italic}mark,.marker{padding:0.1em 0.5em;background:#666;color:#fff;font-size:12px;font-size:0.75rem;text-transform:capitalize}::-webkit-input-placeholder{color:#fff}:-moz-placeholder{color:#fff;opacity:1}::-moz-placeholder{color:#fff;opacity:1}:-ms-input-placeholder{color:#fff}img{max-width:100%;height:auto;vertical-align:top}.media-box iframe{width:100%;height:auto}@media (min-width: 1260px){.desktop-large_hidden {display: none !important;}.desktop-large_visible{display: block !important;}}@media (min-width: 1024px) and (max-width: 1260px){.desktop-small_hidden{display: none !important;}.desktop-small_visible{display: block !important;}}@media (min-width: 320px) and (max-width: 767px){.mobile_hidden{display:none !important}.mobile_visible{display:block !important}}@media (min-width: 768px) and (max-width: 1023px){.tablet_hidden{display:none !important}.tablet_visible{display:block !important}}</style>
  <link type="text/css" rel="stylesheet" href="//www.csnphilly.com/sites/csnphilly/files/advagg_css/css__HPZzeVUkLT68D1FJTmzQto_2nl_dTK2F4C6ByyI-3Lw__YWa25Sh5pYu4XTzwg-N6B8w7Jx0Vh80vJQobD_eqNKc__5yqLz-XBMHLBqVcTATCYcx-7793XaTRQzABKSNj0HY4.css" media="all" />
<link type="text/css" rel="stylesheet" href="//www.csnphilly.com/sites/csnphilly/files/advagg_css/css__2s4LqmS7ajL_KL-83VOLNecXRUa0_NAbMWIwTIdvTts__YuoyovkbmHwxLlrZHLKnw5NoaojJrrSU-wvZaGcqXKg__5yqLz-XBMHLBqVcTATCYcx-7793XaTRQzABKSNj0HY4.css" media="all" />
<link type="text/css" rel="stylesheet" href="//www.csnphilly.com/sites/csnphilly/files/advagg_css/css__ZXyMdBl0buLF8vLGEao7S86RM2CjJz0jVh1zJsNr_Zg__SOEpjpUBnWWE2_JN2f--e5_YxWOtkCh9ZAupV88y-FA__5yqLz-XBMHLBqVcTATCYcx-7793XaTRQzABKSNj0HY4.css" media="all" />
<link type="text/css" rel="stylesheet" href="//www.csnphilly.com/sites/csnphilly/files/advagg_css/css__5P_0jIZnMez5K_C4iVqitqQABi6t0hv0ofNOh9qkdx8__RgsDjfBGPnQdIzJY9taMYyn3Us0vafGLz8pn4VmtwvE__5yqLz-XBMHLBqVcTATCYcx-7793XaTRQzABKSNj0HY4.css" media="all" />
  <!-- Script for catch errors on Js error testing.
       It should goes before Drupal scripts array and any placed script -->
  <script>
    window.jsErrors = [];
    window.onerror = function(errorMessage) {
      window.jsErrors[window.jsErrors.length] = errorMessage;
    };
  </script>
  <script type="text/javascript" src="//www.csnphilly.com/sites/csnphilly/files/advagg_js/js__dU859nniAHOO3ZZ49DZUXr5Frl9T3QSa81hYdDf9Uas__JILlNGib1Hz87izGwrCoeUVWHEurARtSrto0pJK-26Q__5yqLz-XBMHLBqVcTATCYcx-7793XaTRQzABKSNj0HY4.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
var mpscall = {"site":"rsn-web","path":"\/node\/516466","title":"Flyers likely to end up with one of two top centermen in draft","qs":"cD15YTVuYmNzJm9jaWQ9eWFob28meXB0cj15YWhvbz9zcmM9cnNz","content_id":"node516466","is_content":"1","type":"article","cag":{"author":"Tim-Panaccio-CSNPhilly-com","league":"NHL","section":"Philadelphia-Flyers","sport":"Hockey","tags":"2017-NHL-draft|NHL|Philadelphia-Flyers|ron-hextall|Tim-Panaccio","team":"Philadelphia-Flyers","field-videos":"Do-Flyers-need-to-tweak-or-completely-overhaul-team"},"pubdate":"1493651735"}
var mpsopts = {"host":"mps.nbcuni.com","updatecorrelator":"1"}
var mps=mps||{};mps._ext=mps._ext||{};mps._adsheld=[];mps._queue=mps._queue||{};mps._queue.gptloaded=mps._queue.gptloaded||[];mps.__timer=Date.now();mps.__intcode="v2"; "function"!=typeof mps.getAd&&(mps.getAd=function(a){if("string"!=typeof a)return!1;var b="mps-getad-"+a.replace(/\W/g,"");mps._ext&&mps._ext.loaded||(mps._queue.gptloaded.push(function(){"function"==typeof mps._gptfirst&&mps._gptfirst();mps.insertAd("#"+b,a)}),mps._adsheld.push(a));return'<div id="'+b+'" class="mps-wrapper" data-mps-fill-slot="'+a+'"></div>'});(function(){head=document.head||document.getElementsByTagName("head")[0];mpsload=document.createElement("script");mpsload.src="//"+mpsopts.host+"/fetch/ext/load-"+mpscall.site+".js?nowrite=2";mpsload.id="mps-load";head.insertBefore(mpsload,head.firstChild)})();
//--><!]]>
</script>
<script type="text/javascript" src="//www.csnphilly.com/sites/csnphilly/files/advagg_js/js__lj8t3ZR9OqxjIdO80SOoTUeOBlfyvG2iv79lCDM3QBQ__V2hfJDBXK4gkwi4KglCyTp89c9iUvEm_w_q7gs3-ZFw__5yqLz-XBMHLBqVcTATCYcx-7793XaTRQzABKSNj0HY4.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
document.createElement( "picture" );
//--><!]]>
</script>
<script type="text/javascript" src="//www.csnphilly.com/sites/csnphilly/files/advagg_js/js__ZPSNIc2V1mJcmCsS8dAa4wjhJEDPUDXiLclnt1wyQJo__RJ9xi9wU_oAnYHhFY0XWtFBkVimQ6UfUNThk7quaoZA__5yqLz-XBMHLBqVcTATCYcx-7793XaTRQzABKSNj0HY4.js" async="async"></script>
<script type="text/javascript" src="//www.csnphilly.com/sites/csnphilly/files/advagg_js/js___Weo722cMICqp_44WWk_lcjyIQB-yadh-caReRrGI18__O4A57Sv5pz88_XnltO_gB5wHXvKWgKesy_ZA-iNCclg__5yqLz-XBMHLBqVcTATCYcx-7793XaTRQzABKSNj0HY4.js" async="async"></script>
<script type="text/javascript" src="//www.csnphilly.com/sites/csnphilly/files/advagg_js/js__j_mvU6GjInKTuW3uzP34uzA_5OlaotUyiatneT2SiWY__97TX66XCItf69p6-4twvumMIpchbZVLDVdG7Ce3zN1A__5yqLz-XBMHLBqVcTATCYcx-7793XaTRQzABKSNj0HY4.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
  window._taboola = window._taboola || [];
  _taboola.push({article:'auto'});
  !function (e, f, u) {
    e.async = 1;
    e.src = u;
    f.parentNode.insertBefore(e, f);
  }(document.createElement('script'), document.getElementsByTagName('script')[0], 'http://cdn.taboola.com/libtrc/nbcsports-csnphilly/loader.js');
//--><!]]>
</script>
<script type="text/javascript" src="//www.csnphilly.com/sites/csnphilly/files/advagg_js/js__UpIagL88__z0aKsv0IxjQ4mipVSe24kwfI5ue003iEU___WyM6b0R1KGOdVG5wfY5ByA_ESETPB9TpoBHvivcNU8__5yqLz-XBMHLBqVcTATCYcx-7793XaTRQzABKSNj0HY4.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
window.__gigyaConf = {"enabledProviders":"*","sessionExpiration":2000000,"connectWithoutLoginBehavior":"loginExistingUser"}
//--><!]]>
</script>
<script type="text/javascript" src="//cdn.gigya.com/JS/socialize.js?apikey=2_3rumFoOLHMSkaq_mWUW7YuObxet4CY5o29LoxTPi2uGIN0WWApoONCp6ynBW-a6m&amp;lang=en"></script>
<script type="text/javascript" src="//www.csnphilly.com/sites/csnphilly/files/advagg_js/js__NRBPtqXMfbnJnF-PrIangoYFOAhOS15PVR831iTDPYc__neeA2WYzvW7iFDxEaMLmZeh0A_inBsJJmSp2FuF-9ks__5yqLz-XBMHLBqVcTATCYcx-7793XaTRQzABKSNj0HY4.js"></script>
<script type="text/javascript" src="//www.csnphilly.com/sites/csnphilly/files/advagg_js/js__vgkAU7ftKvruRwfVcgbGzRP4sejSp5trysC_1C5Rtbo__qZ94Wuw8nP9OidqrZTPVyh5pF2ogBAbTpvL9ZYpwd7I__5yqLz-XBMHLBqVcTATCYcx-7793XaTRQzABKSNj0HY4.js"></script>
<script type="text/javascript" src="//www.csnphilly.com/sites/csnphilly/files/advagg_js/js__BHbH70wS7-F90kHyP54oL4hqEmk1FqPhmrI9TPl8Tak__ml4144ZU23dDWLgm95iCVeMdpCa_uz8znrMUGpmoZN0__5yqLz-XBMHLBqVcTATCYcx-7793XaTRQzABKSNj0HY4.js"></script>
<script type="text/javascript">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</script>
</head>
<body class="html not-front not-logged-in page-node page-node- page-node-516466 node-type-article rsn-site rsn-site-csnphilly has-two-sidebars" >
    
  <header id="nbcsports-fixed-header">

    <!-- start Primary Nav -->
    <nav id="nbcsports-primary-nav">
                  <a href="http://www.csnphilly.com" id="home-page-link"></a>  <a href="http://www.csnphilly.com/philadelphia-eagles" class="dynamic-nav-link" data-tid="171">Eagles</a>  <a href="http://www.csnphilly.com/philadelphia-flyers" class="dynamic-nav-link" data-tid="201">Flyers</a>  <a href="http://www.csnphilly.com/phillies" class="dynamic-nav-link">Phillies</a>  <a href="http://www.csnphilly.com/philadelphia-76ers" class="dynamic-nav-link" data-tid="216">Sixers</a>  <a href="http://www.csnphilly.com/philadelphia-union" class="dynamic-nav-link" data-tid="231">Union</a>  <a href="http://www.csnphilly.com/video" class="dynamic-nav-link" data-tid="126">Video</a>  <a href="http://www.csnphilly.com/live" class="dynamic-nav-link">Stream</a>  <a href="http://www.csnphilly.com/podcasts" class="dynamic-nav-link">Podcasts</a>  <a href="http://www.csnphilly.com/the700level" class="dynamic-nav-link" data-tid="731">The700Level</a>  <a href="http://www.csnphilly.com/ncaa" class="dynamic-nav-link" data-tid="256">NCAA</a>  <a href="http://www.csnphilly.com/alerts" class="dynamic-nav-link">Alerts</a>  <a href="http://csnphilly.com/tomboy" class="dynamic-nav-link">TOMBOY</a>  <a href="http://www.csnphilly.com/philadelphia-region-high-school-football-scoreboard" class="dynamic-nav-link">High Schools</a>  <a href="http://www.csnphilly.com/picknclick" class="dynamic-nav-link">Pick &#039;n Click</a>  <a href="http://www.csnphilly.com/philadelphia-soul" class="dynamic-nav-link" data-tid="246">Soul</a>  <a href="http://phillysportsbars.com/" class="dynamic-nav-link">Sports Bars</a>  <a href="http://www.csnphilly.com/page/comcast-network" class="dynamic-nav-link">TCN</a>
<span id="more-nav-btn" class="no-select no-more-links" unselectable="on" tabindex="0">MORE</span>
    </nav>
    <!-- end Primary Nav -->

    <!-- start More Nav -->
    <nav id="more-nav" class="no-more-links">
    </nav>
    <!-- end More Nav -->

    <!-- start Secondary Nav -->
    <nav id="nbcsports-secondary-nav">
        
<div class="nbcsports-secondary-nav__wrapper">

        <a href="http://csnphilly.com/flyersstream">Stream the Flyers</a>        <a href="http://www.csnphilly.com/live-faq">Streaming FAQ</a>        <a href="http://stats.csnphilly.com/gz/hockey/nhl/team/4968">In-Game Live</a>        <a href="http://stats.csnphilly.com/nhl/teamstats.asp?teamno=15&amp;type=schedule">Schedule</a>        <a href="http://stats.csnphilly.com/nhl/standings_conference.asp">Standings</a>        <a href="http://stats.csnphilly.com/nhl/teamstats.asp?teamno=15&amp;type=stats">Stats</a>        <a href="http://stats.csnphilly.com/nhl/teamstats.asp?teamno=15&amp;type=roster">Roster</a>        <a href="http://www.csnphilly.com/video/category/861">Video</a>        <a href="http://csnphilly.com/flyers-pulse">Pulse</a>        <a href="http://www.comcastsportsnet.com/" class="rsn-local-nav">Comcast SportsNet</a>        <a href="http://www.golfchannel.com" class="golf-channel-nav">Golf Channel</a>        <a href="http://www.rotoworld.com" class="rotoworld-nav">Rotoworld</a>  
  <div id="nbcsports-search-box">
    <form action="http://www.csnphilly.com/search" class="search-form" method="get" autocomplete="off">
      <span class="icon"></span>
      <label>Search</label>
      <input type="search" name="search_api_views_fulltext" id="nbcsports-search" placeholder="Search CSN Philadelphia" tabindex="0"/>
    </form>
  </div>

</div>
    </nav>
    <!-- end Secondary Nav -->

  </header>
  <!-- end #nbcsports-fixed-header -->

  <div id="wrapper">
    <div id="outer">
      <!-- Start leaderboard -->
      <div id="nbcsports-leaderboard">
                    <div class="region region-top-region">
    <div id="block-mps-topbanner" class="block block-mps">

    
  <div class="content">
    <div id="topbanner"><script>typeof(mps)=='object' && typeof(mps.getAd)=='function' && document.write(mps.getAd('topbanner'));</script></div>  </div>
</div>
  </div>
              </div>
      <!-- End leaderboard -->

      <!-- Start scoreboard -->
              <div id="nbcsports-scoreboard">
            <div class="region region-scoreboard">
    <div class="scoreboard with_ad">
  <iframe id="scoreboard-ticker" src="http://csnphilly.stats.com/score_ticker/index.html?sports=NHL%7CLOCAL%7CMLB%7CNFL%7CNBA%7CNASCAR%7CCFB%7CCBK%7CEPL%7CFORM1%7CGOLF%7CMLS%7CCYCLING"></iframe>
</div>
<div id="block-mps-scorelogo" class="block block-mps">

    
  <div class="content">
    <div id="scorelogo"><script>typeof(mps)=='object' && typeof(mps.getAd)=='function' && document.write(mps.getAd('scorelogo'));</script></div>  </div>
</div>
  </div>
        </div>
            <!-- Start scoreboard -->

      <!-- Start content wrapper -->
      <div id="nbcsports-content-wrapper">

        <aside id="nbcsports-live-extra-widget">
                        <div class="region region-left-rail">
    <div id="block-bean-highlights-vod-flyers" class="block block-bean">

    
  <div class="content">
    <div  class="vod-content">
  <a href="http://www.csnphilly.com/live" class="link link_type-block"><div class=""></div></a>
  <header class="title vod-content__title">
    <span class="title-text">Flyers Analysis</span>
  </header>
  <div class="vod-content__scrollbox">
    <div class="vod-content__events" id="vod-touch-events">
      <div class="events-list vod-content__events-list">
        <ul class="list events-list__list">
                      <li class="list__item">
    <div class="vod-content__event">
    <div class="media-thumb">
            <a id="media-card-link-512051" class="link link_type-block link_type-play" href="http://www.csnphilly.com/video/do-flyers-need-tweak-or-completely-overhaul-team">
        <span class="media-thumb__thumb">
          <picture >
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="http://www.csnphilly.com/sites/csnphilly/files/styles/half_6__desktop_large_/public/2017/04/18/hextall-slide.jpg?itok=e5jQSCY0&amp;timestamp=1492491721 1x, http://www.csnphilly.com/sites/csnphilly/files/styles/half_6__desktop_large_2x_/public/2017/04/18/hextall-slide.jpg?itok=y87I0GRi&amp;timestamp=1492491721 2x" media="(min-width: 1260px)" />
<source srcset="http://www.csnphilly.com/sites/csnphilly/files/styles/half_6__desktop_large_/public/2017/04/18/hextall-slide.jpg?itok=e5jQSCY0&amp;timestamp=1492491721 1x, http://www.csnphilly.com/sites/csnphilly/files/styles/half_6__desktop_large_2x_/public/2017/04/18/hextall-slide.jpg?itok=y87I0GRi&amp;timestamp=1492491721 2x" media="(min-width: 1024px)" />
<source srcset="http://www.csnphilly.com/sites/csnphilly/files/styles/half_6__desktop_large_/public/2017/04/18/hextall-slide.jpg?itok=e5jQSCY0&amp;timestamp=1492491721 1x, http://www.csnphilly.com/sites/csnphilly/files/styles/half_6__desktop_large_2x_/public/2017/04/18/hextall-slide.jpg?itok=y87I0GRi&amp;timestamp=1492491721 2x" media="(min-width: 768px)" />
<source srcset="http://www.csnphilly.com/sites/csnphilly/files/styles/half_6__desktop_large_/public/2017/04/18/hextall-slide.jpg?itok=e5jQSCY0&amp;timestamp=1492491721 1x, http://www.csnphilly.com/sites/csnphilly/files/styles/half_6__desktop_large_2x_/public/2017/04/18/hextall-slide.jpg?itok=y87I0GRi&amp;timestamp=1492491721 2x" media="(min-width: 320px)" />
<!--[if IE 9]></video><![endif]-->
<img  src="http://www.csnphilly.com/sites/csnphilly/files/styles/half_6__desktop_large_/public/2017/04/18/hextall-slide.jpg?itok=e5jQSCY0&amp;timestamp=1492491721" alt="" title="" />
</picture>          <span class="play-btn"></span>
                      <div class="video-duration-overlay">1:36</div>
                  </span>
        <span class="media-thumb__title">Do Flyers need to tweak or completely overhaul team?</span>
      </a>
          </div>
  </div>
  </li>
                      <li class="list__item">
    <div class="vod-content__event">
    <div class="media-thumb">
            <a id="media-card-link-512111" class="link link_type-block link_type-play" href="http://www.csnphilly.com/video/who-was-blame-flyers-disappointing-season">
        <span class="media-thumb__thumb">
          <picture >
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="http://www.csnphilly.com/sites/csnphilly/files/styles/half_6__desktop_large_/public/2017/04/18/flyers-disapp-slide.jpg?itok=1wIQLoha&amp;timestamp=1492491063 1x, http://www.csnphilly.com/sites/csnphilly/files/styles/half_6__desktop_large_2x_/public/2017/04/18/flyers-disapp-slide.jpg?itok=HIk31ql3&amp;timestamp=1492491063 2x" media="(min-width: 1260px)" />
<source srcset="http://www.csnphilly.com/sites/csnphilly/files/styles/half_6__desktop_large_/public/2017/04/18/flyers-disapp-slide.jpg?itok=1wIQLoha&amp;timestamp=1492491063 1x, http://www.csnphilly.com/sites/csnphilly/files/styles/half_6__desktop_large_2x_/public/2017/04/18/flyers-disapp-slide.jpg?itok=HIk31ql3&amp;timestamp=1492491063 2x" media="(min-width: 1024px)" />
<source srcset="http://www.csnphilly.com/sites/csnphilly/files/styles/half_6__desktop_large_/public/2017/04/18/flyers-disapp-slide.jpg?itok=1wIQLoha&amp;timestamp=1492491063 1x, http://www.csnphilly.com/sites/csnphilly/files/styles/half_6__desktop_large_2x_/public/2017/04/18/flyers-disapp-slide.jpg?itok=HIk31ql3&amp;timestamp=1492491063 2x" media="(min-width: 768px)" />
<source srcset="http://www.csnphilly.com/sites/csnphilly/files/styles/half_6__desktop_large_/public/2017/04/18/flyers-disapp-slide.jpg?itok=1wIQLoha&amp;timestamp=1492491063 1x, http://www.csnphilly.com/sites/csnphilly/files/styles/half_6__desktop_large_2x_/public/2017/04/18/flyers-disapp-slide.jpg?itok=HIk31ql3&amp;timestamp=1492491063 2x" media="(min-width: 320px)" />
<!--[if IE 9]></video><![endif]-->
<img  src="http://www.csnphilly.com/sites/csnphilly/files/styles/half_6__desktop_large_/public/2017/04/18/flyers-disapp-slide.jpg?itok=1wIQLoha&amp;timestamp=1492491063" alt="" title="" />
</picture>          <span class="play-btn"></span>
                      <div class="video-duration-overlay">2:55</div>
                  </span>
        <span class="media-thumb__title">Who was to blame for Flyers&#039; disappointing season?</span>
      </a>
          </div>
  </div>
  </li>
                      <li class="list__item">
    <div class="vod-content__event">
    <div class="media-thumb">
            <a id="media-card-link-512071" class="link link_type-block link_type-play" href="http://www.csnphilly.com/video/should-flyers-trade-some-defensive-youth-bolster-offense">
        <span class="media-thumb__thumb">
          <picture >
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="http://www.csnphilly.com/sites/csnphilly/files/styles/half_6__desktop_large_/public/2017/04/18/ghost-slide.jpg?itok=Avcb4Ik5&amp;timestamp=1492491662 1x, http://www.csnphilly.com/sites/csnphilly/files/styles/half_6__desktop_large_2x_/public/2017/04/18/ghost-slide.jpg?itok=AnSTFRPg&amp;timestamp=1492491662 2x" media="(min-width: 1260px)" />
<source srcset="http://www.csnphilly.com/sites/csnphilly/files/styles/half_6__desktop_large_/public/2017/04/18/ghost-slide.jpg?itok=Avcb4Ik5&amp;timestamp=1492491662 1x, http://www.csnphilly.com/sites/csnphilly/files/styles/half_6__desktop_large_2x_/public/2017/04/18/ghost-slide.jpg?itok=AnSTFRPg&amp;timestamp=1492491662 2x" media="(min-width: 1024px)" />
<source srcset="http://www.csnphilly.com/sites/csnphilly/files/styles/half_6__desktop_large_/public/2017/04/18/ghost-slide.jpg?itok=Avcb4Ik5&amp;timestamp=1492491662 1x, http://www.csnphilly.com/sites/csnphilly/files/styles/half_6__desktop_large_2x_/public/2017/04/18/ghost-slide.jpg?itok=AnSTFRPg&amp;timestamp=1492491662 2x" media="(min-width: 768px)" />
<source srcset="http://www.csnphilly.com/sites/csnphilly/files/styles/half_6__desktop_large_/public/2017/04/18/ghost-slide.jpg?itok=Avcb4Ik5&amp;timestamp=1492491662 1x, http://www.csnphilly.com/sites/csnphilly/files/styles/half_6__desktop_large_2x_/public/2017/04/18/ghost-slide.jpg?itok=AnSTFRPg&amp;timestamp=1492491662 2x" media="(min-width: 320px)" />
<!--[if IE 9]></video><![endif]-->
<img  src="http://www.csnphilly.com/sites/csnphilly/files/styles/half_6__desktop_large_/public/2017/04/18/ghost-slide.jpg?itok=Avcb4Ik5&amp;timestamp=1492491662" alt="" title="" />
</picture>          <span class="play-btn"></span>
                      <div class="video-duration-overlay">1:20</div>
                  </span>
        <span class="media-thumb__title">Should Flyers trade some defensive youth to bolster offense?</span>
      </a>
          </div>
  </div>
  </li>
                      <li class="list__item">
    <div class="vod-content__event">
    <div class="media-thumb">
            <a id="media-card-link-512076" class="link link_type-block link_type-play" href="http://www.csnphilly.com/video/claude-giroux-injured-or-past-his-prime">
        <span class="media-thumb__thumb">
          <picture >
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="http://www.csnphilly.com/sites/csnphilly/files/styles/half_6__desktop_large_/public/2017/04/18/giroux-slide.jpg?itok=Xb95u3YQ&amp;timestamp=1492491662 1x, http://www.csnphilly.com/sites/csnphilly/files/styles/half_6__desktop_large_2x_/public/2017/04/18/giroux-slide.jpg?itok=4BgGXL1K&amp;timestamp=1492491662 2x" media="(min-width: 1260px)" />
<source srcset="http://www.csnphilly.com/sites/csnphilly/files/styles/half_6__desktop_large_/public/2017/04/18/giroux-slide.jpg?itok=Xb95u3YQ&amp;timestamp=1492491662 1x, http://www.csnphilly.com/sites/csnphilly/files/styles/half_6__desktop_large_2x_/public/2017/04/18/giroux-slide.jpg?itok=4BgGXL1K&amp;timestamp=1492491662 2x" media="(min-width: 1024px)" />
<source srcset="http://www.csnphilly.com/sites/csnphilly/files/styles/half_6__desktop_large_/public/2017/04/18/giroux-slide.jpg?itok=Xb95u3YQ&amp;timestamp=1492491662 1x, http://www.csnphilly.com/sites/csnphilly/files/styles/half_6__desktop_large_2x_/public/2017/04/18/giroux-slide.jpg?itok=4BgGXL1K&amp;timestamp=1492491662 2x" media="(min-width: 768px)" />
<source srcset="http://www.csnphilly.com/sites/csnphilly/files/styles/half_6__desktop_large_/public/2017/04/18/giroux-slide.jpg?itok=Xb95u3YQ&amp;timestamp=1492491662 1x, http://www.csnphilly.com/sites/csnphilly/files/styles/half_6__desktop_large_2x_/public/2017/04/18/giroux-slide.jpg?itok=4BgGXL1K&amp;timestamp=1492491662 2x" media="(min-width: 320px)" />
<!--[if IE 9]></video><![endif]-->
<img  src="http://www.csnphilly.com/sites/csnphilly/files/styles/half_6__desktop_large_/public/2017/04/18/giroux-slide.jpg?itok=Xb95u3YQ&amp;timestamp=1492491662" alt="" title="" />
</picture>          <span class="play-btn"></span>
                      <div class="video-duration-overlay">3:08</div>
                  </span>
        <span class="media-thumb__title">Claude Giroux: Injured or past his prime?</span>
      </a>
          </div>
  </div>
  </li>
                      <li class="list__item">
    <div class="vod-content__event">
    <div class="media-thumb">
            <a id="media-card-link-512106" class="link link_type-block link_type-play" href="http://www.csnphilly.com/video/will-oskar-lindblom-have-role-flyers-next-season">
        <span class="media-thumb__thumb">
          <picture >
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="http://www.csnphilly.com/sites/csnphilly/files/styles/half_6__desktop_large_/public/2017/04/18/lindblom.jpg?itok=Mt4KyF98&amp;timestamp=1492491063 1x, http://www.csnphilly.com/sites/csnphilly/files/styles/half_6__desktop_large_2x_/public/2017/04/18/lindblom.jpg?itok=QgwbYFOo&amp;timestamp=1492491063 2x" media="(min-width: 1260px)" />
<source srcset="http://www.csnphilly.com/sites/csnphilly/files/styles/half_6__desktop_large_/public/2017/04/18/lindblom.jpg?itok=Mt4KyF98&amp;timestamp=1492491063 1x, http://www.csnphilly.com/sites/csnphilly/files/styles/half_6__desktop_large_2x_/public/2017/04/18/lindblom.jpg?itok=QgwbYFOo&amp;timestamp=1492491063 2x" media="(min-width: 1024px)" />
<source srcset="http://www.csnphilly.com/sites/csnphilly/files/styles/half_6__desktop_large_/public/2017/04/18/lindblom.jpg?itok=Mt4KyF98&amp;timestamp=1492491063 1x, http://www.csnphilly.com/sites/csnphilly/files/styles/half_6__desktop_large_2x_/public/2017/04/18/lindblom.jpg?itok=QgwbYFOo&amp;timestamp=1492491063 2x" media="(min-width: 768px)" />
<source srcset="http://www.csnphilly.com/sites/csnphilly/files/styles/half_6__desktop_large_/public/2017/04/18/lindblom.jpg?itok=Mt4KyF98&amp;timestamp=1492491063 1x, http://www.csnphilly.com/sites/csnphilly/files/styles/half_6__desktop_large_2x_/public/2017/04/18/lindblom.jpg?itok=QgwbYFOo&amp;timestamp=1492491063 2x" media="(min-width: 320px)" />
<!--[if IE 9]></video><![endif]-->
<img  src="http://www.csnphilly.com/sites/csnphilly/files/styles/half_6__desktop_large_/public/2017/04/18/lindblom.jpg?itok=Mt4KyF98&amp;timestamp=1492491063" alt="" title="" />
</picture>          <span class="play-btn"></span>
                      <div class="video-duration-overlay">1:20</div>
                  </span>
        <span class="media-thumb__title">Will Lindblom have role with Flyers next season?</span>
      </a>
          </div>
  </div>
  </li>
                      <li class="list__item">
    <div class="vod-content__event">
    <div class="media-thumb">
            <a id="media-card-link-512056" class="link link_type-block link_type-play" href="http://www.csnphilly.com/video/it-time-flyers-switch-5-5-technique">
        <span class="media-thumb__thumb">
          <picture >
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="http://www.csnphilly.com/sites/csnphilly/files/styles/half_6__desktop_large_/public/2017/04/18/5-on-5.jpg?itok=FRvfeoBi&amp;timestamp=1492491721 1x, http://www.csnphilly.com/sites/csnphilly/files/styles/half_6__desktop_large_2x_/public/2017/04/18/5-on-5.jpg?itok=V_EANeqm&amp;timestamp=1492491721 2x" media="(min-width: 1260px)" />
<source srcset="http://www.csnphilly.com/sites/csnphilly/files/styles/half_6__desktop_large_/public/2017/04/18/5-on-5.jpg?itok=FRvfeoBi&amp;timestamp=1492491721 1x, http://www.csnphilly.com/sites/csnphilly/files/styles/half_6__desktop_large_2x_/public/2017/04/18/5-on-5.jpg?itok=V_EANeqm&amp;timestamp=1492491721 2x" media="(min-width: 1024px)" />
<source srcset="http://www.csnphilly.com/sites/csnphilly/files/styles/half_6__desktop_large_/public/2017/04/18/5-on-5.jpg?itok=FRvfeoBi&amp;timestamp=1492491721 1x, http://www.csnphilly.com/sites/csnphilly/files/styles/half_6__desktop_large_2x_/public/2017/04/18/5-on-5.jpg?itok=V_EANeqm&amp;timestamp=1492491721 2x" media="(min-width: 768px)" />
<source srcset="http://www.csnphilly.com/sites/csnphilly/files/styles/half_6__desktop_large_/public/2017/04/18/5-on-5.jpg?itok=FRvfeoBi&amp;timestamp=1492491721 1x, http://www.csnphilly.com/sites/csnphilly/files/styles/half_6__desktop_large_2x_/public/2017/04/18/5-on-5.jpg?itok=V_EANeqm&amp;timestamp=1492491721 2x" media="(min-width: 320px)" />
<!--[if IE 9]></video><![endif]-->
<img  src="http://www.csnphilly.com/sites/csnphilly/files/styles/half_6__desktop_large_/public/2017/04/18/5-on-5.jpg?itok=FRvfeoBi&amp;timestamp=1492491721" alt="" title="" />
</picture>          <span class="play-btn"></span>
                      <div class="video-duration-overlay">1:28</div>
                  </span>
        <span class="media-thumb__title">Is it time for Flyers to switch up 5-on-5 technique?</span>
      </a>
          </div>
  </div>
  </li>
                      <li class="list__item">
    <div class="vod-content__event">
    <div class="media-thumb">
            <a id="media-card-link-512101" class="link link_type-block link_type-play" href="http://www.csnphilly.com/video/will-nick-cousins-end-vegas-next-season">
        <span class="media-thumb__thumb">
          <picture >
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="http://www.csnphilly.com/sites/csnphilly/files/styles/half_6__desktop_large_/public/2017/04/18/cousisn-slide.jpg?itok=_u5f9eqE&amp;timestamp=1492491063 1x, http://www.csnphilly.com/sites/csnphilly/files/styles/half_6__desktop_large_2x_/public/2017/04/18/cousisn-slide.jpg?itok=GBv2sYZ1&amp;timestamp=1492491063 2x" media="(min-width: 1260px)" />
<source srcset="http://www.csnphilly.com/sites/csnphilly/files/styles/half_6__desktop_large_/public/2017/04/18/cousisn-slide.jpg?itok=_u5f9eqE&amp;timestamp=1492491063 1x, http://www.csnphilly.com/sites/csnphilly/files/styles/half_6__desktop_large_2x_/public/2017/04/18/cousisn-slide.jpg?itok=GBv2sYZ1&amp;timestamp=1492491063 2x" media="(min-width: 1024px)" />
<source srcset="http://www.csnphilly.com/sites/csnphilly/files/styles/half_6__desktop_large_/public/2017/04/18/cousisn-slide.jpg?itok=_u5f9eqE&amp;timestamp=1492491063 1x, http://www.csnphilly.com/sites/csnphilly/files/styles/half_6__desktop_large_2x_/public/2017/04/18/cousisn-slide.jpg?itok=GBv2sYZ1&amp;timestamp=1492491063 2x" media="(min-width: 768px)" />
<source srcset="http://www.csnphilly.com/sites/csnphilly/files/styles/half_6__desktop_large_/public/2017/04/18/cousisn-slide.jpg?itok=_u5f9eqE&amp;timestamp=1492491063 1x, http://www.csnphilly.com/sites/csnphilly/files/styles/half_6__desktop_large_2x_/public/2017/04/18/cousisn-slide.jpg?itok=GBv2sYZ1&amp;timestamp=1492491063 2x" media="(min-width: 320px)" />
<!--[if IE 9]></video><![endif]-->
<img  src="http://www.csnphilly.com/sites/csnphilly/files/styles/half_6__desktop_large_/public/2017/04/18/cousisn-slide.jpg?itok=_u5f9eqE&amp;timestamp=1492491063" alt="" title="" />
</picture>          <span class="play-btn"></span>
                      <div class="video-duration-overlay">1:19</div>
                  </span>
        <span class="media-thumb__title">Will Cousins end up in Vegas next season?</span>
      </a>
          </div>
  </div>
  </li>
                      <li class="list__item">
    <div class="vod-content__event">
    <div class="media-thumb">
            <a id="media-card-link-512081" class="link link_type-block link_type-play" href="http://www.csnphilly.com/video/wayne-simmonds-flyers-best-player">
        <span class="media-thumb__thumb">
          <picture >
<!--[if IE 9]><video style="display: none;"><![endif]-->
<source srcset="http://www.csnphilly.com/sites/csnphilly/files/styles/half_6__desktop_large_/public/2017/04/18/simmonds-slide.jpg?itok=dFO5kMXf&amp;timestamp=1492491662 1x, http://www.csnphilly.com/sites/csnphilly/files/styles/half_6__desktop_large_2x_/public/2017/04/18/simmonds-slide.jpg?itok=pzSb_gfR&amp;timestamp=1492491662 2x" media="(min-width: 1260px)" />
<source srcset="http://www.csnphilly.com/sites/csnphilly/files/styles/half_6__desktop_large_/public/2017/04/18/simmonds-slide.jpg?itok=dFO5kMXf&amp;timestamp=1492491662 1x, http://www.csnphilly.com/sites/csnphilly/files/styles/half_6__desktop_large_2x_/public/2017/04/18/simmonds-slide.jpg?itok=pzSb_gfR&amp;timestamp=1492491662 2x" media="(min-width: 1024px)" />
<source srcset="http://www.csnphilly.com/sites/csnphilly/files/styles/half_6__desktop_large_/public/2017/04/18/simmonds-slide.jpg?itok=dFO5kMXf&amp;timestamp=1492491662 1x, http://www.csnphilly.com/sites/csnphilly/files/styles/half_6__desktop_large_2x_/public/2017/04/18/simmonds-slide.jpg?itok=pzSb_gfR&amp;timestamp=1492491662 2x" media="(min-width: 768px)" />
<source srcset="http://www.csnphilly.com/sites/csnphilly/files/styles/half_6__desktop_large_/public/2017/04/18/simmonds-slide.jpg?itok=dFO5kMXf&amp;timestamp=1492491662 1x, http://www.csnphilly.com/sites/csnphilly/files/styles/half_6__desktop_large_2x_/public/2017/04/18/simmonds-slide.jpg?itok=pzSb_gfR&amp;timestamp=1492491662 2x" media="(min-width: 320px)" />
<!--[if IE 9]></video><![endif]-->
<img  src="http://www.csnphilly.com/sites/csnphilly/files/styles/half_6__desktop_large_/public/2017/04/18/simmonds-slide.jpg?itok=dFO5kMXf&amp;timestamp=1492491662" alt="" title="" />
</picture>          <span class="play-btn"></span>
                      <div class="video-duration-overlay">2:23</div>
                  </span>
        <span class="media-thumb__title">Is Simmonds the Flyers&#039; best player?</span>
      </a>
          </div>
  </div>
  </li>
                  </ul>
      </div>
    </div>
  </div>
  <footer class="vod-content__footer"></footer>
</div>
  </div>
</div>
  </div>
                  </aside>

        <!-- Start main content -->
        <div id="nbcsports-main" class="clearfix">

                      <div class="tabs">
                          </div>
          
          
                      <div id="nbcsports-content-header" class="content-header content-header_full-width">
                <div class="region region-header">
    <div id="block-nbcs-article-nbcs-article-subscription-bar" class="block block-nbcs-article">

    
  <div class="content">
    
<header id="article-nav">
      <div id="article-social-nav">
      <a href="http://www.csnphilly.com/philadelphia-flyers" class="blog-name">Philadelphia Flyers</a>      <span class="blog-social-buttons">
                <span class="social-button-text"></span>
        <span class="blog-social-button-container">
                      <a href="https://www.facebook.com/csnphilly" class="genericon genericon-facebook" target="_blank"></a>                      <a href="/rss/section/philadelphia-flyers" class="genericon genericon-feed" target="_blank"></a>                      <a href="/alerts" class="genericon genericon-phone" target="_blank"></a>                      <a href="http://email.comcastsportsnet.com/csn/prefp.do" class="genericon genericon-mail" target="_blank"></a>                      <a href="https://twitter.com/CSNPhilly" class="genericon genericon-twitter" target="_blank"></a>                  </span>
              </span>
    </div>
    <!-- #article-social-nav -->
</header>  </div>
</div>
  </div>
            </div>
          
          <div class="main-layout">
            <div class="layout_full-minus-right layout_first dynamic-lede">
              <div class="content-inner">
                                              </div>
            </div>

            <div class="layout_full-minus-right layout_second dynamic-lede">
                <div class="content-inner">
                    <div class="region region-content">
    <div id="block-system-main" class="block block-system">

    
  <div class="content">
    <div class="articles--vod-player-fixed-container"></div>
<div class="articles__wrapper articles__node" data-taxonomy-term="201" data-vocabulary="6" data-active="516466">
  <div class="articles">
    
<article id="post-516466" class="article-module nbcs-article">
      <div class="article-trending-nav-wrapper">
      <ul class="article-trending-nav"><li class="menu-4521 first"><a href="http://csnphilly.com/flyersstream">Stream the Flyers</a></li>
<li class="menu-4526"><a href="http://stats.csnphilly.com/nhl/teamstats.asp?teamno=15&amp;type=schedule">Schedule</a></li>
<li class="menu-4531"><a href="http://stats.csnphilly.com/nhl/standings_conference.asp">Standings</a></li>
<li class="menu-4536"><a href="http://www.csnphilly.com/video/category/861">Video</a></li>
<li class="menu-4541 last"><a href="http://www.csnphilly.com/flyers-pulse">Discuss</a></li>
</ul>    </div>
    <div class="article-midbanner" id="midbanner-516466"></div>
  <span id='chrome-data-post-516466' class="hidden" data-chrome='{"league":"nhl","sport":"hockey","sponsor":""}'></span>
  <header class="entry-header">
    <h2 class="entry-title top">
      Flyers likely to end up with one of two top centermen in draft     </h2>
              <!-- Video replace with player -->
      <div class="image link link_type-play link_type-block nbcs_video_on_demand_wrapper alter" id="vod-wrapper-516466"
         href="http://www.csnphilly.com/video/do-flyers-need-tweak-or-completely-overhaul-team"
         data-video-url="http://vplayer.nbcsports.com/p/BxmELC/philly_article/select/media/Mp1w7f4OSYKg?form=html&autoPlay=true"
         data-video-autoplay="1">
      <img src="/sites/csnphilly/files/styles/article_hero_image/public/2017/04/18/hextall-slide.jpg?itok=ZfiLB6ld" width="656" height="369" alt="hextall-slide.jpg" title="Do Flyers need to tweak or completely overhaul team?" />        <span class="play-btn"></span>
      </div>
          <!-- end Image Or Video Player -->

    <h1 class="entry-title bottom">
      Flyers likely to end up with one of two top centermen in draft     </h1>
    <div class="entry-meta">
      <span class="byline">
        By <a href="/author/tim-panaccio-csnphillycom">Tim Panaccio | CSNPhilly.com</a>        <span class="author vcard"><a class="url fn n" href="#"></a></span>
      </span>
      <span class="posted-on">
        <a href="http://www.csnphilly.com/philadelphia-flyers/flyers-likely-end-one-two-top-centermen-draft"
           rel="bookmark" class="post-permalink">
          <span class="entry-date published">May 01, 2017 11:10 AM</span>
        </a>
      </span>
    </div>
    <!-- .entry-meta -->
          <div class="nbcs_article-social-wrapper">
        <div id="custom-gigya-sharebar-516466" class="custom-gigya-load-sharebar"></div>
        <div class="nbcs_article-comment-wrapper">
          <a href="#respond-516466" id="comments-link-516466" class="comments-link"><span class="comment-count"></span></a>
        </div>
      </div>
      </header>
  <!-- .entry-header -->

  <div class="entry-content entry-content-516466">
    <div class="article-sidebar">
      <div class="article-inline-ad"></div>
                        </div>
    <p>The Flyers made NHL history on Saturday night, becoming the first team to advance to the second pick via the draft lottery from as low as No. 13 overall.</p>
<p>They had just a 2.4 percent chance of advancing 11 spots. And somehow, they did it.</p>
<p>This is only the second time in franchise history the Flyers will be drafting second overall. The&nbsp;last time came in 2007&nbsp;when they chose James van Riemsdyk.</p>
<p>Only once in their entire history have they had the No. 1 overall pick.</p>
<p>That came in 1975&nbsp;when they chose Mel Bridgman. There’s a huge asterisk attached to that.</p>
<p>Then-general manager Keith Allen traded up from 18th —&nbsp;after the Flyers won their second Stanley Cup —&nbsp;and sent Bill Clement, Don McLean, plus that pick to Washington to draft Bridgman.</p>
<p>Now, unless the Flyers deviate from the obvious next month at the NHL draft in Chicago, they will choose either Nolan Patrick or Nico Hischier.&nbsp;</p>
<p>New Jersey owns the top pick and has the choice between the two top centermen.</p>
<p>"I think they're both great players and certainly different," Devils general manager Ray Shero told reporters this weekend. "One's from Switzerland [Hischier] and one's from Canada [Patrick].</p>
<p>"Patrick certainly has lineage. ... He's been through injury this year, but everybody knows he's a heck of a player. [Alex] Galchenyuk in his draft year (2012) didn't really play.</p>
<p>"You get a Swiss kid, you see him, a center iceman who's got size and talent. For us, as a franchise, you've got some real good players here."</p>
<p>Flyers GM Ron Hextall declined to talk about either player.</p>
<p>NHL Central Scouting had Patrick and Hischier in a near dead heat in their final rankings, with Patrick getting the edge at No. 1.</p>
<p>Scouts say both&nbsp;players can make it to the NHL this fall. Yet given Ron Hextall’s patient, careful approach —&nbsp;think of Travis Konecny —&nbsp;it's entirely possible that whomever the Flyers draft will remain in juniors this season for maturation purposes.</p>
<p>That's always been Hextall's thinking.</p>
<p>TSN hockey insider Bob McKenzie is a lifelong devotee to the draft and has seen both players.</p>
<p>"There's no doubt whatsoever in my mind that Nolan Patrick needs to play in the NHL next season," McKenzie told CSNPhilly.com.</p>
<p>"I believe his development would be stunted by going back to the WHL for a fourth year of junior hockey. Patrick only missed being eligible for last year's draft by four days, so he otherwise could've have been drafted into the NHL last season."</p>
<p>The case for or against Hischier's playing now is a bit different because of his size. He’s 176 pounds —&nbsp;22 pounds lighter than Patrick —&nbsp;and could use more muscle, much like Konecny after he was drafted and sent back to juniors in 2015.</p>
<p>"I wouldn't imagine it would necessarily be a bad thing for Hischier to have another year of junior hockey," McKenzie said.</p>
<p>"But his speed, agility, tenacity, skill to make plays and score goals and compete hard would suggest to me he's got a much better than 50-50 chance to be in the NHL next season. In fact, and I could be wrong on this, I would bet he's in the NHL next season."</p>
<p>Some scouts have compared Hischier to Washington’s Nicklas Backstrom, which says tons about his overall ability.</p>
<p>Mike Morreale, NHL.com's draft expert, said he expects both Patrick and Hischier to play in the NHL this fall.</p>
<p>One more thing: Because Hischier (age 19) is on loan to Halifax from SC Bern, he falls under European draftee status, meaning he is eligible to play in the AHL next season, even though he won’t be 20.&nbsp;</p>
<p>Given&nbsp;Hextall’s reluctance to play rookies right away, this certainly changes how the Flyers might look upon Hischier because it gives them the&nbsp;flexibility to get Hischier pro experience in the AHL before making the jump to the NHL.</p>
<p><strong>Giroux Foundation</strong><br>The Claude Giroux Foundation announced the distribution of more than $70,000 raised through charity events to Children's Hospital of Philadelphia, The Ed Snider Youth Hockey Foundation, Still Strong Foundation, Silver Springs School and Fondation de l'Hôpital Notre-Dame Hospital Foundation.</p>
<p>"It's a real privilege and honor to lend my support, especially to children," Giroux said. "Making a difference in a child's life is something I take great pride in and will continue to do so for years to come."</p>
  </div>
  <!-- .entry-content -->

  <footer class="entry-footer">
          <span class="tags-links">Tags: <a href="/tags/2017-nhl-draft" rel="tag">2017 NHL draft</a>, <a href="/tags/nhl" rel="tag">NHL</a>, <a href="/tags/philadelphia-flyers" rel="tag">Philadelphia Flyers</a>, <a href="/tags/ron-hextall" rel="tag">ron hextall</a>, <a href="/tags/tim-panaccio" rel="tag">Tim Panaccio</a></span>
        <div class="comments-container">
              <div id="respond-516466">
          <div id="516466" class="comments custom-gigya-load-comments-button"></div>
          <div id="custom-gigya-comments-for-516466"></div>
        </div>
          </div>
    <div id="taboola-container-thumbs-post-516466"></div>
    <div id="taboola-container-text-links-post-516466"></div>
  </footer>
  <!-- .entry-footer -->
</article>

<article id="post-516671" class="article-module nbcs-article">
      <div class="article-trending-nav-wrapper">
      <ul class="article-trending-nav"><li class="menu-4521 first"><a href="http://csnphilly.com/flyersstream">Stream the Flyers</a></li>
<li class="menu-4526"><a href="http://stats.csnphilly.com/nhl/teamstats.asp?teamno=15&amp;type=schedule">Schedule</a></li>
<li class="menu-4531"><a href="http://stats.csnphilly.com/nhl/standings_conference.asp">Standings</a></li>
<li class="menu-4536"><a href="http://www.csnphilly.com/video/category/861">Video</a></li>
<li class="menu-4541 last"><a href="http://www.csnphilly.com/flyers-pulse">Discuss</a></li>
</ul>    </div>
    <div class="article-midbanner" id="midbanner-516671"></div>
  <span id='chrome-data-post-516671' class="hidden" data-chrome='{"league":"nhl","sport":"hockey","sponsor":""}'></span>
  <header class="entry-header">
    <h2 class="entry-title top">
      NHL Playoffs: Capitals cut Penguins' series lead in OT after Sidney Crosby exits    </h2>
              <!-- Video replace with player -->
      <div class="image link link_type-play link_type-block nbcs_video_on_demand_wrapper alter" id="vod-wrapper-516671"
         href="http://www.csnphilly.com/video/flyers-top-plays-2016-17-season"
         data-video-url="http://vplayer.nbcsports.com/p/BxmELC/philly_article/select/media/c3LqGz_bjs6G?form=html&autoPlay=true"
         data-video-autoplay="1">
      <img src="/sites/csnphilly/files/styles/article_hero_image/public/2017/04/19/apr1817_flyers_1920x1080_923642435982.jpg?itok=ewMS1eDV" width="656" height="369" alt="apr1817_flyers_1920x1080_923642435982.jpg" title="Flyers&#039; top plays of the 2016-17 season" />        <span class="play-btn"></span>
      </div>
          <!-- end Image Or Video Player -->

    <h1 class="entry-title bottom">
      NHL Playoffs: Capitals cut Penguins' series lead in OT after Sidney Crosby exits    </h1>
    <div class="entry-meta">
      <span class="byline">
        By <a href="/author/associated-press">The Associated Press</a>        <span class="author vcard"><a class="url fn n" href="#"></a></span>
      </span>
      <span class="posted-on">
        <a href="http://www.csnphilly.com/philadelphia-flyers/nhl-playoffs-capitals-cut-penguins-series-lead-ot-after-sidney-crosby-exits"
           rel="bookmark" class="post-permalink">
          <span class="entry-date published">May 01, 2017 11:15 PM</span>
        </a>
      </span>
    </div>
    <!-- .entry-meta -->
          <div class="nbcs_article-social-wrapper">
        <div id="custom-gigya-sharebar-516671" class="custom-gigya-load-sharebar"></div>
        <div class="nbcs_article-comment-wrapper">
          <a href="#respond-516671" id="comments-link-516671" class="comments-link"><span class="comment-count"></span></a>
        </div>
      </div>
      </header>
  <!-- .entry-header -->

  <div class="entry-content entry-content-516671">
    <div class="article-sidebar">
      <div class="article-inline-ad"></div>
          </div>
    <p>PITTSBURGH -- A shot from the point by Washington's Kevin Shattenkirk salvaged -- or at the very least, extended -- his team's season.</p>
<p>A far different kind of shot may end up determining the outcome of a playoff series growing more contentious by the shift.</p>
<p>Shattenkirk's goal 3:13 into overtime lifted the Capitals to a 3-2 victory over the Pittsburgh Penguins to cut Pittsburgh's lead to 2-1 in the Eastern Conference semifinal, one that could go on without Penguins star Sidney Crosby.</p>
<p>The Pittsburgh captain left just over 5 minutes into the game after getting cross-checked to the head by Washington's Matt Niskanen. The NHL's leading scorer and one of the game's best players did not return and his status for Wednesday's Game 4 -- and maybe the rest of the postseason -- is uncertain.</p>
<p>"Certainly didn't mean to injure him," said Niskanen, who spent four years with Crosby in Pittsburgh before signing with Washington in 2014. "It's an unfortunate play that happened really quick."</p>
<p>Penguins coach Mike Sullivan said Crosby will be evaluated on Tuesday. Even without Crosby, Pittsburgh pushed Washington to the limit. Evgeni Malkin and Justin Schultz scored in a 48-second span with less than 2 minutes left in regulation to force overtime.</p>
<p>For once Washington, whose 43-year franchise history is littered with playoff collapse after playoff collapse, dominated the extra period before Shattenkirk's flip zipped by Marc-Andre Fleury's blocker to send his teammates pouring over the boards in celebration.</p>
<p>"Tonight was a great test for all of us," said Shattenkirk, who played miserably during a blowout loss in Game 2. "There were a lot of different moments in the game where we had to see what we were made of."</p>
<p>One frightening moment, however, will resonate above all others.</p>
<p>The game was scoreless early in the first period when Crosby skated just outside the Capitals' crease. Washington's Alex Ovechkin slashed Crosby along the upper body and Crosby slid awkwardly trying to maintain his balance when he collided with Niskanen, who had his stick raised.</p>
<p>The stick caught Crosby flush across the mouth and the two-time Hart Trophy winner laid on the ice in pain for several moments before slowly skating off under his own power as Pittsburgh trainers searched the area for Crosby's teeth.</p>
<p>Niskanen earned a major penalty for cross-checking and was given a game misconduct. Washington coach Barry Trotz called it "a hockey play." Niskanen allowed it looked "really bad" when he caught the replay, but stressed there was no malicious intent.</p>
<p>His former teammates weren't buying it.</p>
<p>"It's one of those things you look at it once, you see what actually happened and the next thing is watching how deliberate it was when the guy cross-checks him in the face," Pittsburgh forward Chris Kunitz said. "I thought all of that was kind of out of this league, but I guess not."</p>
<p>This wasn't the first time Crosby took an ugly shot to the head from a Capital. Crosby was in the middle of an MVP run on Jan., 1, 2011, when he took an elbow to the head from Washington's David Steckel during the Winter Classic, leading to a concussion that cost Crosby the better part of two years in his prime as he struggled to recover.</p>
<p>Their captain gone for the rest of the game and perhaps longer, the Penguins appeared momentarily dazed as they tried to regroup.</p>
<p>Washington took a 2-0 lead early in the third period behind goals by Nicklas Backstrom and Evgeny Kuznetzov, rare moments of flow during a static and occasionally ugly three periods that tried to make up in physicality what it lacked in pace of the frenetic opening two games in Washington.</p>
<p>"That's what you have to do in the playoffs," Capitals forward T.J. Oshie said. "You have to play physical and grind it out. We're trying to make this a long series here and the physicality is key for us."</p>
<p>Braden Holtby, yanked after a sloppy second period in Game 2, remained steady during Pittsburgh's second-period surge and the Capitals appeared to be in control when the Penguins pulled Fleury with 3 minutes to go. Then Malkin scored with 1:53 remaining and Schultz tied it 48 seconds later when his blast from the point deflected off Oshie.</p>
<p>No matter. Washington dominated the extra period before Shattenkirk delivered his first goal of the playoffs.</p>
<p>"We came here to win two games," Shattenkirk said. "And next game is going to be even tougher."</p>
<p>Though maybe not as tough as it could be for Pittsburgh if Crosby's familiar No. 87 is out of the lineup.</p>
  </div>
  <!-- .entry-content -->

  <footer class="entry-footer">
          <span class="tags-links">Tags: <a href="/tags/kevin-shattenkirk" rel="tag">Kevin Shattenkirk</a>, <a href="/tags/nhl-playoffs" rel="tag">NHL Playoffs</a>, <a href="/tags/pittsburgh-penguins" rel="tag">Pittsburgh Penguins</a>, <a href="/tags/sidney-crosby" rel="tag">Sidney Crosby</a>, <a href="/tags/washington-capitals" rel="tag">Washington Capitals</a></span>
        <div class="comments-container">
              <div id="respond-516671">
          <div id="516671" class="comments custom-gigya-load-comments-button"></div>
          <div id="custom-gigya-comments-for-516671"></div>
        </div>
          </div>
    <div id="taboola-container-thumbs-post-516671"></div>
    <div id="taboola-container-text-links-post-516671"></div>
  </footer>
  <!-- .entry-footer -->
</article>

<article id="post-516351" class="article-module nbcs-article">
      <div class="article-trending-nav-wrapper">
      <ul class="article-trending-nav"><li class="menu-4521 first"><a href="http://csnphilly.com/flyersstream">Stream the Flyers</a></li>
<li class="menu-4526"><a href="http://stats.csnphilly.com/nhl/teamstats.asp?teamno=15&amp;type=schedule">Schedule</a></li>
<li class="menu-4531"><a href="http://stats.csnphilly.com/nhl/standings_conference.asp">Standings</a></li>
<li class="menu-4536"><a href="http://www.csnphilly.com/video/category/861">Video</a></li>
<li class="menu-4541 last"><a href="http://www.csnphilly.com/flyers-pulse">Discuss</a></li>
</ul>    </div>
    <div class="article-midbanner" id="midbanner-516351"></div>
  <span id='chrome-data-post-516351' class="hidden" data-chrome='{"league":"nhl","sport":"hockey","sponsor":""}'></span>
  <header class="entry-header">
    <h2 class="entry-title top">
      Future Flyers Report: How No. 2 pick changes long-term landscape    </h2>
              <!-- Video replace with player -->
      <div class="image link link_type-play link_type-block nbcs_video_on_demand_wrapper alter" id="vod-wrapper-516351"
         href="http://www.csnphilly.com/video/highlights-bears-eliminate-phantoms-ahl-playoffs-game-5"
         data-video-url="http://vplayer.nbcsports.com/p/BxmELC/philly_article/select/media/nGHsTqmW7ta1?form=html&autoPlay=true"
         data-video-autoplay="1">
      <img src="/sites/csnphilly/files/styles/article_hero_image/public/2017/05/01/043017-phantoms-highlights-web1493613570665_7000k_1920x1080_933444163684.jpg?itok=1z26k5Qi" width="656" height="369" alt="043017-phantoms-highlights-web1493613570665_7000k_1920x1080_933444163684.jpg" title="Highlights: Bears eliminate Phantoms from AHL playoffs in Game 5" />        <span class="play-btn"></span>
      </div>
          <!-- end Image Or Video Player -->

    <h1 class="entry-title bottom">
      Future Flyers Report: How No. 2 pick changes long-term landscape    </h1>
    <div class="entry-meta">
      <span class="byline">
        By <a href="/author/tom-dougherty-csnphillycom">Tom Dougherty | CSNPhilly.com</a>        <span class="author vcard"><a class="url fn n" href="#"></a></span>
      </span>
      <span class="posted-on">
        <a href="http://www.csnphilly.com/philadelphia-flyers/future-flyers-report-how-no-2-pick-changes-long-term-landscape"
           rel="bookmark" class="post-permalink">
          <span class="entry-date published">May 01, 2017 8:50 AM</span>
        </a>
      </span>
    </div>
    <!-- .entry-meta -->
          <div class="nbcs_article-social-wrapper">
        <div id="custom-gigya-sharebar-516351" class="custom-gigya-load-sharebar"></div>
        <div class="nbcs_article-comment-wrapper">
          <a href="#respond-516351" id="comments-link-516351" class="comments-link"><span class="comment-count"></span></a>
        </div>
      </div>
      </header>
  <!-- .entry-header -->

  <div class="entry-content entry-content-516351">
    <div class="article-sidebar">
      <div class="article-inline-ad"></div>
          </div>
    <p><a href="http://www.csnphilly.com/philadelphia-flyers">Flyers</a> general manager Ron Hextall called it a “<a href="http://www.csnphilly.com/philadelphia-flyers/ron-hextall-landing-no-2-overall-pick-big-day-our-franchise">big day for our franchise</a>.”</p>
<p>He was right.</p>
<p>The Flyers on Saturday night somehow beat long odds and landed the No. 2 overall pick in the 2017 NHL draft. The good fortune changed the entire outlook going forward. The Flyers’ long-term trajectory was already on the upswing despite a disappointing season that saw the team miss the playoffs for the third time in five years.</p>
<p>With the pipeline loaded with defensive prospects and goaltenders, the Flyers will now have an opportunity to add an impact forward into the pool <a href="http://www.csnphilly.com/philadelphia-flyers/2017-nhl-draft-prep-options-flyers-no-2"><em><strong>(see draft options)</strong></em></a>. That was not necessarily the case had they drawn the 13th pick, which was the most likely outcome Saturday.</p>
<p>This year’s draft class isn’t considered, by many, to be as deep as those in recent years. Hextall said Saturday that it “isn’t as bad as a draft as people say it is” and “it’s probably an average draft.” He is probably right. Recent years have been special. There was the Connor McDavid and Jack Eichel draft in 2015. Auston Matthews and Patrik Laine last year. Beyond the top two picks, the last two drafts were deep too. The 2015 class was compared to the 2003 draft, <a href="http://www.csnphilly.com/philadelphia-flyers/2015-nhl-draft-what-weve-learned-2003">one of the best drafts</a> in league history. Last year was a solid crop as well.</p>
<p>By many accounts, this year’s class is all about Brandon center Nolan Patrick and Halifax center Nico Hischier, one of whom the Flyers are now guaranteed to snag at No. 2. Either prospect will give the Flyers a forward piece to build around, which will allow their supplementary pieces to fall into their rightful places without any increased pressure.</p>
<p>There is no guarantee that either Patrick or Hischier will provide an immediate impact, or that either of them will make the Flyers’ roster on opening night. But to be able to add a player of their caliber into the fold albeit this season or 2018-19 accomplishes a few things. More importantly, it bides the Flyers <a href="http://www.csnphilly.com/philadelphia-flyers/flyers-can-still-win-claude-giroux-youth-against-clock">more time to win</a> with captain Claude Giroux.</p>
<p>Much has been written about Giroux’s recent decline. Last season, he dealt with confidence issues after offseason hip/abdominal surgery. His numbers have been downturn over the past three seasons. There hasn’t been much help around him, either, but that’s about to change.</p>
<p>Either Patrick or Hischier should give the Flyers a player they can eventually slide into the role as their offensive catalyst, which would take pressure off Giroux to carry the workload as he ages. It also allows Sean Couturier to slide into his role with less outside pressure to live up to expectations as a No. 8 overall pick. There would be less of a burden on Brayden Schenn to score at 5-on-5 and allow him to be a 20-goal per season, power-play specialist.</p>
<p>The point is there should be secondary scoring to mesh with their primary scoring in the coming years. Giroux is 29. Wayne Simmonds is 28. Jakub Voracek is 27. Couturier is just 24. Schenn is 25. Jordan Weal just turned 25. Travis Konecny is only 20. It's still a young group.</p>
<p>Adding either Patrick or Hischier to a prospect group consisting of German Rubtsov and Oskar Lindblom suddenly changes the Flyers’ landscape up front. Konecny made the Flyers as a 19-year-old last year and Lindblom is expected to be here next season. Rubtsov is a year or two away from being NHL ready. Neither Patrick or Hischier will be guaranteed a spot but will have ample opportunity to earn one in training camp. But the Flyers’ future at forward looks at lot brighter today.</p>
<p>Hextall’s plan appears to be injecting more young blood into the lineup in 2017-18. Ivan Provorov and Konecny made the roster last year as 19-year-olds. All signs point to at least two more defensive prospects joining the team next season, with Robert Hagg and Sam Morin being the favorites. (Hagg and Morin both made their NHL debuts during the final week of this season.) Travis Sanheim and Philippe Myers could also push for a spot. If Lindblom doesn't make it, it would be a disappointment.</p>
<p>Landing the No. 2 pick in this year’s draft does another thing: It expedites the Flyers’ timetable to be contenders assuming all goes as planned. Injuries can happen and players don’t pan out as projected, but Patrick and Hischier are what the Flyers desperately need.</p>
<p>A young, dynamic scorer to build around — exactly what the Flyers are looking for.</p>
<p><strong>Quick Hits</strong><br>• The Phantoms were bounced from the AHL playoffs on Sunday night with a 3-2 loss to the Hershey Bears in Game 5 of their best-of-five series. Hershey took a 2-0 series lead before Lehigh Valley battled back to force a Game 5. Per <a href="https://twitter.com/TonyAndrock/status/858829912781840384"><em>Highland Park Hockey</em>’s Tony Androckitis</a>, it’s just the second time ever a road team won every game in an AHL playoff series.</p>
<p>• Sanheim had three assists in five postseason games. He finished his first professional season with 37 points in 76 regular-season games.</p>
<p>• Morin picked up two helpers in five playoffs games with Lehigh Valley. He had 16 points in 74 regular-season games this year. He’s expected to be a Flyer next season.</p>
<p>• Brynäs IF lost to HV71 in the SHL finals. Lindblom will be coming to North America full time next season, while goalie <strong>Felix Sandstrom</strong> could make the jump overseas too.</p>
<p>• <strong>Samuel Dove-McFalls</strong> had a goal and two assists in three games last week. Saint John’s beat Chicoutimi in the QMJHL playoffs and will now face Blainville-Boisbriand in the final.</p>
  </div>
  <!-- .entry-content -->

  <footer class="entry-footer">
          <span class="tags-links">Tags: <a href="/tags/future-flyers-report" rel="tag">Future Flyers Report</a>, <a href="/tags/german-rubtsov" rel="tag">German Rubtsov</a>, <a href="/tags/nico-hischier" rel="tag">Nico Hischier</a>, <a href="/tags/nolan-patrick" rel="tag">Nolan Patrick</a>, <a href="/tags/oskar-lindblom" rel="tag">Oskar Lindblom</a>, <a href="/tags/philadelphia-flyers" rel="tag">Philadelphia Flyers</a>, <a href="/tags/tom-dougherty" rel="tag">Tom Dougherty</a></span>
        <div class="comments-container">
              <div id="respond-516351">
          <div id="516351" class="comments custom-gigya-load-comments-button"></div>
          <div id="custom-gigya-comments-for-516351"></div>
        </div>
          </div>
    <div id="taboola-container-thumbs-post-516351"></div>
    <div id="taboola-container-text-links-post-516351"></div>
  </footer>
  <!-- .entry-footer -->
</article>
  </div>
  <div id="article-loadmore">
    <div class="footer_more-link">
      <a href="/articles/6/201/1" id="load_more_articles" class="use-ajax link link_type-block">Load more</a>    </div>
  </div>
</div>
  </div>
</div>
  </div>
                </div>
            </div>

                        <aside id="nbcsports-right-rail" class="sidebar sidebar_second">
                <div class="region region-right-rail">
    <div id="block-nbcs-article-nbcs-article-rail" class="block block-nbcs-article">

    
  <div class="content">
    <div id="story-explorer-wrapper">
 <aside id="story-explorer" class="styled-scrollbar">
    <div id="story-explorer-headlines">
      <div id="article-rail-ad"></div>
       <div id="article-rail-ad"></div>

<a href="/philadelphia-flyers/nhl-playoffs-capitals-cut-penguins-series-lead-ot-after-sidney-crosby-exits" class="story-explorer-item" id="headline-516671">
  <span class="item-thumbnail"><img src="/sites/csnphilly/files/styles/article_hero_image/public/2017/05/01/usa-alex-ovechkin-kevin-shattenkirk-capitals.jpg?itok=hDNNT_GZ" width="656" height="369" alt="usa-alex-ovechkin-kevin-shattenkirk-capitals.jpg" title="NHL Playoffs: Capitals cut Penguins&#039; series lead in OT after Sidney Crosby exits" /></span>
  <span class="item-headline">NHL Playoffs: Capitals cut Penguins' series lead in OT after Sidney Crosby exits</span>
  <span class="item-timestamp item-add-time-ago" "></span>
</a>

<a href="/philadelphia-flyers/flyers-likely-end-one-two-top-centermen-draft" class="story-explorer-item" id="headline-516466">
  <span class="item-thumbnail"><img src="/sites/csnphilly/files/styles/article_hero_image/public/2017/05/01/ap-ron-hextall.jpg?itok=1c-kG3n-" width="656" height="369" alt="ap-ron-hextall.jpg" title="Flyers likely to end up with one of two top centermen in draft " /></span>
  <span class="item-headline">Flyers likely to end up with one of two top centermen in draft </span>
  <span class="item-timestamp item-add-time-ago" "></span>
</a>

<a href="/philadelphia-flyers/future-flyers-report-how-no-2-pick-changes-long-term-landscape" class="story-explorer-item" id="headline-516351">
  <span class="item-thumbnail"><img src="/sites/csnphilly/files/styles/article_hero_image/public/2017/04/30/zack-hill-flyers-ron-hextall.jpg?itok=3RXC27da" width="656" height="369" alt="zack-hill-flyers-ron-hextall.jpg" title="Future Flyers Report: How No. 2 pick changes long-term landscape" /></span>
  <span class="item-headline">Future Flyers Report: How No. 2 pick changes long-term landscape</span>
  <span class="item-timestamp item-add-time-ago" "></span>
</a>

<a href="/philadelphia-flyers/nhl-playoffs-silfverberg-scores-twice-ducks-beat-oilers-wild-game-3" class="story-explorer-item" id="headline-516366">
  <span class="item-thumbnail"><img src="/sites/csnphilly/files/styles/article_hero_image/public/2017/04/30/usa-ducks-oilers.jpg?itok=1QGCp7YW" width="656" height="369" alt="usa-ducks-oilers.jpg" title="NHL Playoffs: Silfverberg scores twice as Ducks beat Oilers in wild Game 3" /></span>
  <span class="item-headline">NHL Playoffs: Silfverberg scores twice as Ducks beat Oilers in wild Game 3</span>
  <span class="item-timestamp item-add-time-ago" "></span>
</a>

<a href="/philadelphia-flyers/2017-nhl-draft-prep-options-flyers-no-2" class="story-explorer-item" id="headline-516201">
  <span class="item-thumbnail"><img src="/sites/csnphilly/files/styles/article_hero_image/public/2017/04/30/ap-chris-pryor-ron-hextall.jpg?itok=qwaDTxR0" width="656" height="369" alt="ap-chris-pryor-ron-hextall.jpg" title="2017 NHL draft prep: Options for Flyers at No. 2" /></span>
  <span class="item-headline">2017 NHL draft prep: Options for Flyers at No. 2</span>
  <span class="item-timestamp item-add-time-ago" "></span>
</a>

<a href="/philadelphia-flyers/nhl-playoffs-penguins-chase-holtby-beat-capitals-take-2-0-series-lead" class="story-explorer-item" id="headline-516216">
  <span class="item-thumbnail"><img src="/sites/csnphilly/files/styles/article_hero_image/public/2017/04/30/usa-sidney-crosby-marc-andre-fleury.jpg?itok=von5VEST" width="656" height="369" alt="usa-sidney-crosby-marc-andre-fleury.jpg" title="NHL Playoffs: Penguins chase Holtby, beat Capitals to take 2-0 series lead" /></span>
  <span class="item-headline">NHL Playoffs: Penguins chase Holtby, beat Capitals to take 2-0 series lead</span>
  <span class="item-timestamp item-add-time-ago" "></span>
</a>

<a href="/philadelphia-flyers/ron-hextall-landing-no-2-overall-pick-big-day-our-franchise" class="story-explorer-item" id="headline-516151">
  <span class="item-thumbnail"><img src="/sites/csnphilly/files/styles/article_hero_image/public/2017/04/29/csn-ron-hextall.jpg?itok=MHp8zH7C" width="656" height="369" alt="csn-ron-hextall.jpg" title="Ron Hextall on landing No. 2 overall pick: &#039;This is a big day for our franchise&#039;" /></span>
  <span class="item-headline">Ron Hextall on landing No. 2 overall pick: 'This is a big day for our franchise'</span>
  <span class="item-timestamp item-add-time-ago" "></span>
</a>

<a href="/philadelphia-flyers/facing-long-nhl-draft-lottery-odds-flyers-land-2017-no-2-pick" class="story-explorer-item" id="headline-516126">
  <span class="item-thumbnail"><img src="/sites/csnphilly/files/styles/article_hero_image/public/2017/04/30/ap-ron-hextall.jpg?itok=SznJaCzh" width="656" height="369" alt="ap-ron-hextall.jpg" title="Facing long NHL draft lottery odds, Flyers land 2017 No. 2 pick" /></span>
  <span class="item-headline">Facing long NHL draft lottery odds, Flyers land 2017 No. 2 pick</span>
  <span class="item-timestamp item-add-time-ago" "></span>
</a>

<a href="/philadelphia-flyers/nhl-playoffs-cam-talbot-pat-maroon-lead-oilers-2-0-series-lead-over-ducks" class="story-explorer-item" id="headline-515846">
  <span class="item-thumbnail"><img src="/sites/csnphilly/files/styles/article_hero_image/public/2017/04/29/ap-pat-maroon-oilers.jpg?itok=FGgBpMpn" width="656" height="369" alt="ap-pat-maroon-oilers.jpg" title="NHL Playoffs: Cam Talbot, Pat Maroon lead Oilers to 2-0 series lead over Ducks" /></span>
  <span class="item-headline">NHL Playoffs: Cam Talbot, Pat Maroon lead Oilers to 2-0 series lead over Ducks</span>
  <span class="item-timestamp item-add-time-ago" "></span>
</a>

<a href="/philadelphia-flyers/nhl-playoffs-crosby-bonino-lead-penguins-game-1-win-over-caps" class="story-explorer-item" id="headline-515311">
  <span class="item-thumbnail"><img src="/sites/csnphilly/files/styles/article_hero_image/public/2017/04/27/usa-penguins-win-slide.jpg?itok=-IvdaFZX" width="656" height="369" alt="usa-penguins-win-slide.jpg" title="NHL Playoffs: Crosby, Bonino lead Penguins to Game 1 win over Caps" /></span>
  <span class="item-headline">NHL Playoffs: Crosby, Bonino lead Penguins to Game 1 win over Caps</span>
  <span class="item-timestamp item-add-time-ago" "></span>
</a>

<a href="/philadelphia-flyers/flyers-officially-sign-2015-draft-pick-mikhail-vorobyov-entry-level-deal" class="story-explorer-item" id="headline-515046">
  <span class="item-thumbnail"><img src="/sites/csnphilly/files/styles/article_hero_image/public/2017/04/27/ap-flyers-wells-fargo-center-ice-logo.jpg?itok=vnkBsTd-" width="656" height="369" alt="ap-flyers-wells-fargo-center-ice-logo.jpg" title="Flyers officially sign 2015 draft pick Mikhail Vorobyov to entry-level deal" /></span>
  <span class="item-headline">Flyers officially sign 2015 draft pick Mikhail Vorobyov to entry-level deal</span>
  <span class="item-timestamp item-add-time-ago" "></span>
</a>

<a href="/philadelphia-flyers/nhl-playoffs-vernon-fiddler-provides-big-lift-predators-take-1-0-series-lead" class="story-explorer-item" id="headline-514966">
  <span class="item-thumbnail"><img src="/sites/csnphilly/files/styles/article_hero_image/public/2017/04/27/usa-vern-fiddler-predators.jpg?itok=HAtyrgBj" width="656" height="369" alt="usa-vern-fiddler-predators.jpg" title="NHL Playoffs: Vernon Fiddler provides big lift as Predators take 1-0 series lead on Blues" /></span>
  <span class="item-headline">NHL Playoffs: Vernon Fiddler provides big lift as Predators take 1-0 series lead on Blues</span>
  <span class="item-timestamp item-add-time-ago" "></span>
</a>

<a href="/philadelphia-flyers/2016-17-flyers-evaluation-part-2-forwards" class="story-explorer-item" id="headline-514326">
  <span class="item-thumbnail"><img src="/sites/csnphilly/files/styles/article_hero_image/public/2017/04/25/usa-flyers-seven-forwards.jpg?itok=AAzQxsdA" width="656" height="369" alt="usa-flyers-seven-forwards.jpg" title="2016-17 Flyers evaluation: Part 2 of the forwards " /></span>
  <span class="item-headline">2016-17 Flyers evaluation: Part 2 of the forwards </span>
  <span class="item-timestamp item-add-time-ago" "></span>
</a>

<a href="/philadelphia-flyers/report-flyers-sign-2015-draft-pick-mikhail-vorobyov-entry-level-contract" class="story-explorer-item" id="headline-514541">
  <span class="item-thumbnail"><img src="/sites/csnphilly/files/styles/article_hero_image/public/2017/04/25/usa-flyers-flag-logo.jpg?itok=GPJqdbdu" width="656" height="369" alt="usa-flyers-flag-logo.jpg" title="Report: Flyers sign 2015 draft pick Mikhail Vorobyov to entry-level contract" /></span>
  <span class="item-headline">Report: Flyers sign 2015 draft pick Mikhail Vorobyov to entry-level contract</span>
  <span class="item-timestamp item-add-time-ago" "></span>
</a>

<a href="/philadelphia-flyers/2016-17-flyers-evaluation-part-1-forwards" class="story-explorer-item" id="headline-513891">
  <span class="item-thumbnail"><img src="/sites/csnphilly/files/styles/article_hero_image/public/2017/04/23/usa-flyers-eight-forwards.jpg?itok=_3qmI7HM" width="656" height="369" alt="usa-flyers-eight-forwards.jpg" title="2016-17 Flyers evaluation: Part 1 of the forwards" /></span>
  <span class="item-headline">2016-17 Flyers evaluation: Part 1 of the forwards</span>
  <span class="item-timestamp item-add-time-ago" "></span>
</a>

<a href="/philadelphia-flyers/future-flyers-report-shorthanded-net-phantoms-brink-elimination-lose-alex-lyon" class="story-explorer-item" id="headline-513876">
  <span class="item-thumbnail"><img src="/sites/csnphilly/files/styles/article_hero_image/public/2017/04/23/flyers-zack-hill-alex-lyon.jpg?itok=X9LKImRm" width="656" height="369" alt="flyers-zack-hill-alex-lyon.jpg" title="Future Flyers Report: Shorthanded in net, Phantoms on brink of elimination, lose Alex Lyon" /></span>
  <span class="item-headline">Future Flyers Report: Shorthanded in net, Phantoms on brink of elimination, lose Alex Lyon</span>
  <span class="item-timestamp item-add-time-ago" "></span>
</a>

<a href="/philadelphia-flyers/2016-17-flyers-evaluation-defensemen" class="story-explorer-item" id="headline-513581">
  <span class="item-thumbnail"><img src="/sites/csnphilly/files/styles/article_hero_image/public/2017/04/22/usa-flyers-seven-defensemen.jpg?itok=Cr-5B9Be" width="656" height="369" alt="usa-flyers-seven-defensemen.jpg" title="2016-17 Flyers evaluation: Defensemen" /></span>
  <span class="item-headline">2016-17 Flyers evaluation: Defensemen</span>
  <span class="item-timestamp item-add-time-ago" "></span>
</a>

<a href="/philadelphia-flyers/nhl-playoffs-senators-capitals-advance-close-out-1st-round" class="story-explorer-item" id="headline-513871">
  <span class="item-thumbnail"><img src="/sites/csnphilly/files/styles/article_hero_image/public/2017/04/23/usa-alex-ovechkin-auston-matthews.jpg?itok=Dylgv2a3" width="656" height="369" alt="usa-alex-ovechkin-auston-matthews.jpg" title="NHL Playoffs: Senators, Capitals advance to close out 1st round" /></span>
  <span class="item-headline">NHL Playoffs: Senators, Capitals advance to close out 1st round</span>
  <span class="item-timestamp item-add-time-ago" "></span>
</a>

<a href="/philadelphia-flyers/report-kings-name-john-stevens-head-coach" class="story-explorer-item" id="headline-513801">
  <span class="item-thumbnail"><img src="/sites/csnphilly/files/styles/article_hero_image/public/2017/04/23/ap-john-stevens-kings.jpg?itok=Jqzuw7Oy" width="656" height="369" alt="ap-john-stevens-kings.jpg" title="Report: Kings to name John Stevens head coach" /></span>
  <span class="item-headline">Report: Kings to name John Stevens head coach</span>
  <span class="item-timestamp item-add-time-ago" "></span>
</a>

<a href="/philadelphia-flyers/2016-17-flyers-evaluation-goaltending" class="story-explorer-item" id="headline-513431">
  <span class="item-thumbnail"><img src="/sites/csnphilly/files/styles/article_hero_image/public/2017/04/22/usa-michal-neuvirth-steve-mason-anthony-stolarz-flyers-goalies.jpg?itok=ZVpMtfgd" width="656" height="369" alt="usa-michal-neuvirth-steve-mason-anthony-stolarz-flyers-goalies.jpg" title="2016-17 Flyers evaluation: Goaltending" /></span>
  <span class="item-headline">2016-17 Flyers evaluation: Goaltending</span>
  <span class="item-timestamp item-add-time-ago" "></span>
</a>
<div id="story-explorer-legal">
  </div>
    </div>
  </aside>
</div>
  </div>
</div>
  </div>
            </aside>
                      </div>

        </div>
        <!-- End main content -->

      </div>
      <!-- End content wrapper -->

      <!-- Start footer -->
      <footer id="nbcsports-footer">
          <div class="region region-footer">
    <div id="block-bean-flyers-suffix" class="block block-bean block-bean-custom-block block-type-custom-block block-type-custom-block-double">

    
  <div class="content">
    <div class="entity entity-bean bean-custom-block clearfix">

  <div class="content">
    <div class="field field-name-field-content field-type-text-long field-label-hidden"><div class="field-items"><div class="field-item even"> <p class="text" style="font-style: italic;"><a style="color:#1788c1!important;" href="http://email.comcastsportsnet.com/csn/prefp.do">NEWSLETTER SIGN-UP: Never miss any Philly sports news.</a></p>  

<script type="text/javascript" src="http://digitalassets.nbcsports.com/rsn/csnphilly/jquery-3.1.1.min.js"></script>
<script type="text/javascript">
$( ".text" ).insertBefore( $( ".tags-links" ) );
</script></div></div></div>  </div>
</div>
  </div>
</div>
<div id="block-block-6" class="block block-block">

    
  <div class="content">
    <style>

.sections-list .link {
    color: #fff;
}


</style>  </div>
</div>
<div id="block-nbcs-footer-nbcs-footer" class="block block-nbcs-footer">

    
  <div class="content">
    <div id="footer-left">
  <div id="footer-logo"></div>
  <div id="footer-social-links">
    <span id="follow-us">FOLLOW US</span>
          <a href="http://facebook.com/csnphilly" class="genericon genericon-facebook">Facebook</a>          <a href="http://twitter.com/csnphilly" class="genericon genericon-twitter">Twitter</a>          <a href="http://plus.google.com/+csnphilly" class="genericon genericon-googleplus">Google Plus</a>          <a href="http://instagram.com/csnphilly" class="genericon genericon-instagram">Instagram</a>      </div>
  <div id="copyright">©2017 Comcast SportsNet Philadelphia, L.P.</div>
  <div id="footer-site-links">
          <a href="http://www.nbcuniversal.com/">A Division of NBC Universal</a>          <a href="/tags/press-releases">Press Releases </a>          <a href="/contact-us">Contact Us</a>          <a href="http://www.nbcunicareers.com/">Employment Opportunities</a>          <a href="http://www.csnphilly.com/csn-internships">Internships</a>          <a href="/terms-service">Terms of Service</a>          <a href="http://www.nbcuniversal.com/privacy">Privacy Policy</a>          <a href="/page/purchase-policy">Purchase Policy</a>          <a href="/comcast-sportsnet/advertise-us">Advertise</a>          <a href="/advertising-guidelines">Advertising Guidelines</a>          <a href="/closed-captioning">Closed Captioning</a>          <a href="/channel-finder">Channel Finder</a>          <a href="http://corporate.comcast.com/news-information/nbcuniversal-transaction/independent-programming">Independent Programming Report</a>          <a href="http://www.csnphilly.com/live-faq">Live FAQ</a>          <a href="/ontv">TV Listings</a>          <a href="http://info.evidon.com/pub_info/267?v=1">Ad Choices</a>      </div>
</div>
<div id="footer-right">
  <div id="footer-newsletter-link">
        <span id="newsletter-banner">GET NEWSLETTERS &amp; ALERTS</span>&#13;
    <a href="http://email.comcastsportsnet.com/csn/prefp.do" id="newsletter-link">SIGN UP</a>   </div>
</div>
  </div>
</div>
  </div>
      </footer>
      <!-- End footer -->

    </div><!-- end #outer -->
  </div><!-- end #wrapper -->
  <!-- SiteCatalyst code version: 1.7.0
Copyright 1996-2017 Adobe, Inc. -->
<script type="text/javascript" src="/sites/all/modules/custom/nbcs_sitecatalyst/js/nbcs_adobe.js?ooyjrd"></script>
<script type="text/javascript"><!--

var nbcscontenthub="nbcs.contenthub";
s.contextData[nbcscontenthub]="News";
var nbcsteam="nbcs.team";
s.contextData[nbcsteam]="Philadelphia Flyers";
var nbcsleague="nbcs.league";
s.contextData[nbcsleague]="NHL";
var nbcssport="nbcs.sport";
s.contextData[nbcssport]="Hockey";
var nbcsauthor="nbcs.author";
s.contextData[nbcsauthor]="Tim Panaccio | CSNPhilly.com";
var nbcssubfeature="nbcs.subfeature";
s.contextData[nbcssubfeature]="Philadelphia Flyers";
var nbcscontenttype="nbcs.contenttype";
s.contextData[nbcscontenttype]="Story";
var nbcscontentid="nbcs.contentid";
s.contextData[nbcscontentid]="516466";
var nbcscontenttitle="nbcs.contenttitle";
s.contextData[nbcscontenttitle]="Flyers likely to end up with one of two top centermen in draft ";
var nbcspagenumber="nbcs.pagenumber";
s.contextData[nbcspagenumber]=1;
var nbcsrelease_version="nbcs.release_version";
s.contextData[nbcsrelease_version]="1.26.1";
/************* DO NOT ALTER ANYTHING BELOW THIS LINE ! **************/
var s_code=s.t();if(s_code)document.write(s_code)//--></script>
<script type="text/javascript"><!--
if(navigator.appVersion.indexOf('MSIE')>=0)document.write(unescape('%3C')+'\!-'+'-')
//--></script>
<noscript><img src="http://examplecom.112.2O7.net/b/ss/examplecom/1/H.20.3--NS/0/559706" height="1" width="1" alt=""></noscript>
<!--/DO NOT REMOVE/-->
<!-- End SiteCatalyst code version: 1.7.0 -->
<script type="text/javascript" src="//www.csnphilly.com/sites/csnphilly/files/advagg_js/js__lOCAh6_G2-syfSonbl_eRlz9mAnNDG7xohglRBwEoSo__GS5ds9kzIoBH1l_hrriHCM_VLQv5drEonElm4bMePaA__5yqLz-XBMHLBqVcTATCYcx-7793XaTRQzABKSNj0HY4.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
typeof(mps)=='object' && typeof(mps.writeFooter)=='function' && mps.writeFooter();
//--><!]]>
</script>
<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","licenseKey":"cf07660617","applicationID":"15907363","transactionName":"ZQNbZ0cAX0UEABdcCVxJeFBBCF5YSg0MUQNtFlhUUD5HXwAU","queueTime":0,"applicationTime":528,"atts":"SURYEQ8aTEs=","errorBeacon":"bam.nr-data.net","agent":""}</script></body>
</html>
